Vulnerabilities

Vulnerability · CVE-2025-59790

Improper Privilege Management vulnerability in Apache Kvrocks.

Published Nov 28, 2025 · catalog updated Nov 28, 2025 · Apache Software Foundation Apache Kvrocks

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-59790. EPSS is 0.44%. Act only if a listed version of Apache Software Foundation Apache Kvrocks is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.44%
Remediation
Vendor / distro source
Affected products
vendor Apache Software Foundation Apache Kvrocks 2.9.0 ≤2.13.0

Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Apache Software Foundation Apache Kvrocks 2.9.0 ≤2.13.02.9.0 ≤2.13.0

How to fix CVE-2025-59790

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-59790. EPSS is 0.44%. Act only if a listed version of Apache Software Foundation Apache Kvrocks is installed.

Which versions are affected?

Compare what you have installed with Apache Software Foundation Apache Kvrocks 2.9.0 ≤2.13.0 2.9.0 ≤2.13.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 28, 2025 · EUVD

    Detected

    Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.

  2. Nov 28, 2025 · EUVD

    Updated

    Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.

Sources

  • CVE.orgVulnerability recordCVE-2025-59790

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-59790

    30-day exploitation probability 0.44%

    first.org
  • EUVDVulnerability recordEUVD-2025-199878

    Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 4, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 28, 2026