Security fix · CVE-2025-59830
Rack is a modular Ruby web server interface.
Published Sep 25, 2025 · catalog updated Oct 19, 2026 · Rack is a modular
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-59830. EPSS is 0.57%. Act only if a listed version of Rack is a modular is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Rack is a modular).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-34835 · Medium
- CVE-2026-34827 · High
- CVE-2026-32762 · Medium
- CVE-2026-26962 · Medium
- CVE-2026-34830 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.57%
- Remediation
- Version ranges on file
- Affected products
- cpe rack/rack · vendor rack rack < 2.2.18
Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe rack/rackversion unspecified
- vendor rack rack < 2.2.18< 2.2.18
How to fix CVE-2025-59830
Upgrade
CVE-2025-59830 lists a fix boundary at 2.2.18. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.2.18
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-59830. EPSS is 0.57%. Act only if a listed version of Rack is a modular is installed.
Which versions are affected?
Compare what you have installed with rack rack < 2.2.18 < 2.2.18. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-400: Uncontrolled Resource Consumption; CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.57%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 25, 2025 · NIST NVD
Detected
Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default conf
Oct 19, 2026 · NIST NVD
Updated
Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default conf
Sources
- CVE.orgVulnerability recordCVE-2025-59830
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-59830
30-day exploitation probability 0.57%
first.org - EUVDVulnerability recordEUVD-2025-31103
Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submi
euvd.enisa.europa.eu - NIST NVDVulnerability recordCVE-2025-59830
Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submi
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- EUVDOct 23, 2026
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- NIST NVDOct 19, 2026