Vulnerability · CVE-2025-60355
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
Published Oct 28, 2025 · catalog updated Oct 27, 2026 · zhangyd-c OneBlog v2.3.9 and
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-60355. EPSS is 0.53%. Act only if a listed version of zhangyd-c OneBlog v2.3.9 and is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (zhangyd-c OneBlog v2.3.9 and).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.53%
- Remediation
- Version ranges on file
- Affected products
- cpe zhyd/oneblog · vendor n/a n/a n/a
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe zhyd/oneblog< 2.3.9
- vendor n/a n/a n/an/a
How to fix CVE-2025-60355
Upgrade
CVE-2025-60355 lists a fix boundary at 2.3.9. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.3.9
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-60355. EPSS is 0.53%. Act only if a listed version of zhangyd-c OneBlog v2.3.9 and is installed.
Which versions are affected?
Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine. EPSS 0.53%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 28, 2025 · EUVD
Detected
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
Mar 4, 2026 · EUVD
Updated
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
Oct 27, 2026 · NIST NVD
Updated
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
Sources
- CVE.orgVulnerability recordCVE-2025-60355
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-60355
30-day exploitation probability 0.53%
first.org - EUVDVulnerability recordEUVD-2025-36547
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
euvd.enisa.europa.eu - NIST NVDVulnerability recordCVE-2025-60355
zhangyd-c OneBlog v2.3.9 and before was vulnerable to SSTI (Server-Side Template Injection) via FreeMarker templates.
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- NIST NVDOct 27, 2026
- FIRST EPSSOct 25, 2026
- CVE.orgOct 24, 2026
- EUVDOct 24, 2026