Vulnerabilities

Vulnerability · CVE-2025-60514

Tillywork v0.1.3 and below is vulnerable to SQL Injection in app/common/helpers/query.builder.helper.ts.

Published Oct 17, 2025 · catalog updated Oct 17, 2025 · Tillywork v0.1.3 and below

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-60514. EPSS is 0.29%. Act only if a listed version of Tillywork v0.1.3 and below is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Tillywork v0.1.3 and below).
  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.29%
Remediation
Vendor / distro source
Affected products
vendor n/a n/a n/a

Tillywork v0.1.3 and below is vulnerable to SQL Injection in app/common/helpers/query.builder.helper.ts.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor n/a n/a n/an/a

How to fix CVE-2025-60514

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-60514. EPSS is 0.29%. Act only if a listed version of Tillywork v0.1.3 and below is installed.

Which versions are affected?

Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.29%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 17, 2025 · EUVD

    Detected

    Tillywork v0.1.3 and below is vulnerable to SQL Injection in app/common/helpers/query.builder.helper.ts.

  2. Oct 17, 2025 · EUVD

    Updated

    Tillywork v0.1.3 and below is vulnerable to SQL Injection in app/common/helpers/query.builder.helper.ts.

Sources

  • CVE.orgVulnerability recordCVE-2025-60514

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-60514

    30-day exploitation probability 0.29%

    first.org
  • EUVDVulnerability recordEUVD-2025-34898

    Tillywork v0.1.3 and below is vulnerable to SQL Injection in app/common/helpers/query.builder.helper.ts.

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 4, 2026
  • CVE.orgOct 26, 2026
  • EUVDOct 26, 2026