Vulnerability · CVE-2025-60799
phpPgAdmin 7.13.0 and earlier contains an incorrect access control vulnerability in sql.php at lines 68-76.
Published Nov 20, 2025 · catalog updated Nov 20, 2025 · phpPgAdmin 7.13.0 and earlier
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2025-60799 is not in CISA KEV. FIRST estimates a 22.00% chance of exploitation in the next 30 days. Check whether you run phpPgAdmin 7.13.0 and earlier.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (phpPgAdmin 7.13.0 and earlier).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-107079 · Unknown
- CVE-2026-95168 · High
- CVE-2025-60475 · Medium
- CVE-2025-60494 · Unknown
- CVE-2025-60496 · Unknown
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 22.00%
- Remediation
- Version ranges on file
- Affected products
- stated n/a · vendor n/a n/a n/a
phpPgAdmin 7.13.0 and earlier contains an incorrect access control vulnerability in sql.php at lines 68-76. The application allows unauthorized manipulation of session variables by accepting user-controlled parameters ('subject', 'server', 'database', 'queryid') without proper validation or access control checks. Attackers can exploit this to store arbitrary SQL queries in $_SESSION['sqlquery'] by manipulating these parameters, potentially leading to session poisoning, stored cross-site scripting, or unauthorized access to sensitive session data.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- stated n/a<= 7.13.0
- vendor n/a n/a n/an/a
How to fix CVE-2025-60799
Upgrade
CVE-2025-60799 lists a fix boundary at 7.13.0. Compare the installed build with that boundary before you change production.
Version check
Affected <= 7.13.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2025-60799 is not in CISA KEV. FIRST estimates a 22.00% chance of exploitation in the next 30 days. Check whether you run phpPgAdmin 7.13.0 and earlier.
Which versions are affected?
Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 22.00%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 20, 2025 · EUVD
Detected
phpPgAdmin 7.13.0 and earlier contains an incorrect access control vulnerability in sql.php at lines 68-76. The application allows unauthorized manipulation of session variables by accepting user-controlled parameters ('subject', 'server', 'database', 'queryid') without proper validation or access control checks. Attackers can exploit this to store arbitrary SQL queries in $_SESSION['sqlquery'] by
Nov 20, 2025 · EUVD
Updated
phpPgAdmin 7.13.0 and earlier contains an incorrect access control vulnerability in sql.php at lines 68-76. The application allows unauthorized manipulation of session variables by accepting user-controlled parameters ('subject', 'server', 'database', 'queryid') without proper validation or access control checks. Attackers can exploit this to store arbitrary SQL queries in $_SESSION['sqlquery'] by
Sources
- CVE.orgVulnerability recordCVE-2025-60799
Official CVE identifier
cve.org - EUVDVulnerability recordEUVD-2025-198260
phpPgAdmin 7.13.0 and earlier contains an incorrect access control vulnerability in sql.php at lines 68-76. The application allows unauthorized manipulation of session variables by accepting user-controlled parameters ('subject', 'server', 'database', 'queryid') without proper va
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 20, 2025. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026