Vulnerability · CVE-2025-61659
bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.
Published Sep 29, 2025 · catalog updated Oct 15, 2025 · bash-git-prompt 2.6.1 through 2.7.1
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-61659. EPSS is 0.14%. Act only if a listed version of bash-git-prompt 2.6.1 through 2.7.1 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (bash-git-prompt 2.6.1 through 2.7.1).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.14%
- Remediation
- Vendor / distro source
- Affected products
- vendor magicmonty bash-git-prompt 2.6.1 ≤2.7.1
bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor magicmonty bash-git-prompt 2.6.1 ≤2.7.12.6.1 ≤2.7.1
How to fix CVE-2025-61659
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 2.6.1 ≤2.7.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-61659. EPSS is 0.14%. Act only if a listed version of bash-git-prompt 2.6.1 through 2.7.1 is installed.
Which versions are affected?
Compare what you have installed with magicmonty bash-git-prompt 2.6.1 ≤2.7.1 2.6.1 ≤2.7.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.14%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 29, 2025 · EUVD
Detected
bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.
Oct 15, 2025 · EUVD
Updated
bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.
Sources
- CVE.orgVulnerability recordCVE-2025-61659
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-61659
30-day exploitation probability 0.14%
first.org - EUVDVulnerability recordEUVD-2025-31584
bash-git-prompt 2.6.1 through 2.7.1 insecurely uses the /tmp/git-index-private$$ file, which has a predictable name.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 23, 2026
- FIRST EPSSOct 23, 2026
- EUVDOct 23, 2026