Vulnerability · CVE-2025-6167
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5.
Published Jun 17, 2025 · catalog updated Jun 17, 2025 · A vulnerability classified as
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-6167. EPSS is 0.77%. Act only if a listed version of A vulnerability classified as is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A vulnerability classified as).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.77%
- Remediation
- Vendor / distro source
- Affected products
- vendor themanojdesai python-a2a 0.5.4
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor themanojdesai python-a2a 0.5.40.5.4
How to fix CVE-2025-6167
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 0.5.4
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-6167. EPSS is 0.77%. Act only if a listed version of A vulnerability classified as is installed.
Which versions are affected?
Compare what you have installed with themanojdesai python-a2a 0.5.4 0.5.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.77%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jun 17, 2025 · EUVD
Detected
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Jun 17, 2025 · EUVD
Updated
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Sources
- CVE.orgVulnerability recordCVE-2025-6167
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-6167
30-day exploitation probability 0.77%
first.org - EUVDVulnerability recordEUVD-2025-18486
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this is
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026