Vulnerabilities

Security fix · CVE-2025-61915

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems.

Published Nov 29, 2025 · catalog updated Dec 3, 2025 · OpenPrinting

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-61915. EPSS is 0.50%. Act only if a listed version of OpenPrinting is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.0
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.50%
Remediation
Version ranges on file
Affected products
vendor OpenPrinting cups < 2.4.15

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor OpenPrinting cups < 2.4.15< 2.4.15

How to fix CVE-2025-61915

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-61915. EPSS is 0.50%. Act only if a listed version of OpenPrinting is installed.

Which versions are affected?

Compare what you have installed with OpenPrinting cups < 2.4.15 < 2.4.15. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.50%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 29, 2025 · EUVD

    Detected

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

  2. Dec 3, 2025 · EUVD

    Updated

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

Sources

  • CVE.orgVulnerability recordCVE-2025-61915

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-61915

    30-day exploitation probability 0.50%

    first.org
  • EUVDVulnerability recordEUVD-2025-199891

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 2, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 27, 2026