Vulnerabilities

Vulnerability · CVE-2025-62235

Authentication Bypass by Spoofing vulnerability in Apache NimBLE.

Published Jan 10, 2026 · catalog updated Jan 12, 2026 · Apache Software Foundation Apache Mynewt NimBLE

Last checked Nov 3, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-62235. EPSS is 0.38%. Act only if a listed version of Apache Software Foundation Apache Mynewt NimBLE is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.38%
Remediation
Vendor / distro source
Affected products
vendor Apache Software Foundation Apache Mynewt NimBLE 0 ≤1.8.0

Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Apache Software Foundation Apache Mynewt NimBLE 0 ≤1.8.00 ≤1.8.0

How to fix CVE-2025-62235

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-62235. EPSS is 0.38%. Act only if a listed version of Apache Software Foundation Apache Mynewt NimBLE is installed.

Which versions are affected?

Compare what you have installed with Apache Software Foundation Apache Mynewt NimBLE 0 ≤1.8.0 0 ≤1.8.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.38%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 10, 2026 · EUVD

    Detected

    Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.

  2. Jan 12, 2026 · EUVD

    Updated

    Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Sources

  • CVE.orgVulnerability recordCVE-2025-62235

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-62235

    30-day exploitation probability 0.38%

    first.org
  • EUVDVulnerability recordEUVD-2026-1851

    Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, whi

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 3, 2026
  • CVE.orgOct 31, 2026
  • EUVDOct 30, 2026