Vulnerabilities

Security fix · CVE-2025-62372

vLLM is an inference and serving engine for large language models (LLMs).

Published Nov 21, 2025 · catalog updated Nov 24, 2025 · vLLM is an inference

Last checked Oct 31, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-62372. EPSS is 0.41%. Act only if a listed version of vLLM is an inference is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (vLLM is an inference).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.41%
Remediation
Version ranges on file
Affected products
vendor vllm-project vllm 0.5.5, < 0.11.1

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor vllm-project vllm 0.5.5, < 0.11.10.5.5, < 0.11.1

How to fix CVE-2025-62372

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-62372. EPSS is 0.41%. Act only if a listed version of vLLM is an inference is installed.

Which versions are affected?

Compare what you have installed with vllm-project vllm 0.5.5, < 0.11.1 0.5.5, < 0.11.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 21, 2025 · EUVD

    Detected

    vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue

  2. Nov 24, 2025 · EUVD

    Updated

    vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue

Sources

  • CVE.orgVulnerability recordCVE-2025-62372

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-62372

    30-day exploitation probability 0.41%

    first.org
  • EUVDVulnerability recordEUVD-2025-198357

    vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong),

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 31, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 28, 2026