Vulnerability · CVE-2025-62411
LibreNMS is a community-based GPL-licensed network monitoring system.
Published Oct 16, 2025 · catalog updated Oct 16, 2025 · LibreNMS is a community-based
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2025-62411 is not in CISA KEV. FIRST estimates a 12.72% chance of exploitation in the next 30 days. Check whether you run LibreNMS is a community-based.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (LibreNMS is a community-based).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-109357 · Critical
- CVE-2026-109352 · Medium
- CVE-2024-51092 · Critical
- CVE-2026-6204 · High
- CVE-2026-2728 · Medium
- Severity
- Medium5.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 12.72%
- Remediation
- Version ranges on file
- Affected products
- vendor librenms librenms < 25.10.0
LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation or output encoding. This leads to arbitrary JavaScript execution in the admin’s browser. This vulnerability is fixed in 25.10.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor librenms librenms < 25.10.0< 25.10.0
How to fix CVE-2025-62411
Upgrade
CVE-2025-62411 lists a fix boundary at 25.10.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 25.10.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2025-62411 is not in CISA KEV. FIRST estimates a 12.72% chance of exploitation in the next 30 days. Check whether you run LibreNMS is a community-based.
Which versions are affected?
Compare what you have installed with librenms librenms < 25.10.0 < 25.10.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 12.72%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 16, 2025 · EUVD
Detected
LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation o
Oct 16, 2025 · EUVD
Updated
LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation o
Sources
- CVE.orgVulnerability recordCVE-2025-62411
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-62411
30-day exploitation probability 12.72%
first.org - EUVDVulnerability recordEUVD-2025-34785
LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport na
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 26, 2026
- CVE.orgOct 26, 2026
- EUVDOct 26, 2026