Vulnerability · CVE-2025-62412
LibreNMS is a community-based GPL-licensed network monitoring system.
Published Oct 16, 2025 · catalog updated Oct 16, 2025 · LibreNMS is a community-based
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-62412. EPSS is 0.28%. Act only if a listed version of LibreNMS is a community-based is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (LibreNMS is a community-based).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-109357 · Critical
- CVE-2026-109352 · Medium
- CVE-2026-86426 · Critical · known exploited
- CVE-2024-51092 · Critical
- CVE-2026-6204 · High
- Severity
- Low3.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.28%
- Remediation
- Version ranges on file
- Affected products
- vendor librenms librenms < 25.10.0
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor librenms librenms < 25.10.0< 25.10.0
How to fix CVE-2025-62412
Upgrade
CVE-2025-62412 lists a fix boundary at 25.10.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 25.10.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-62412. EPSS is 0.28%. Act only if a listed version of LibreNMS is a community-based is installed.
Which versions are affected?
Compare what you have installed with librenms librenms < 25.10.0 < 25.10.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 16, 2025 · EUVD
Detected
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
Oct 16, 2025 · EUVD
Updated
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
Sources
- CVE.orgVulnerability recordCVE-2025-62412
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-62412
30-day exploitation probability 0.28%
first.org - EUVDVulnerability recordEUVD-2025-34819
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- CVE.orgOct 26, 2026
- EUVDOct 26, 2026