Vulnerability · CVE-2025-62416
Bagisto is an open source laravel eCommerce platform.
Published Oct 16, 2025 · catalog updated Oct 17, 2025 · Bagisto Bagisto
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-62416. EPSS is 0.40%. Act only if a listed version of Bagisto Bagisto is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-60120 · Medium
- CVE-2025-62415 · Medium
- CVE-2025-62418 · Medium
- CVE-2025-62414 · Medium
- CVE-2025-62417 · High
- Severity
- Medium5.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.40%
- Remediation
- Version ranges on file
- Affected products
- vendor Bagisto Bagisto < 2.3.8
Bagisto is an open source laravel eCommerce platform. Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product creation privileges to inject arbitrary template expressions that are evaluated by the backend — potentially leading to Remote Code Execution (RCE) on the server. This vulnerability is fixed in 2.3.8.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Bagisto Bagisto < 2.3.8< 2.3.8
How to fix CVE-2025-62416
Upgrade
CVE-2025-62416 lists a fix boundary at 2.3.8. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.3.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-62416. EPSS is 0.40%. Act only if a listed version of Bagisto Bagisto is installed.
Which versions are affected?
Compare what you have installed with Bagisto Bagisto < 2.3.8 < 2.3.8. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.40%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 16, 2025 · EUVD
Detected
Bagisto is an open source laravel eCommerce platform. Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product creation privileges to inject arbitrary template expressions that are evaluated by the backend — potentially leading to
Oct 17, 2025 · EUVD
Updated
Bagisto is an open source laravel eCommerce platform. Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product creation privileges to inject arbitrary template expressions that are evaluated by the backend — potentially leading to
Sources
- CVE.orgVulnerability recordCVE-2025-62416
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-62416
30-day exploitation probability 0.40%
first.org - EUVDVulnerability recordEUVD-2025-34816
Bagisto is an open source laravel eCommerce platform. Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 26, 2026
- CVE.orgOct 26, 2026
- EUVDOct 26, 2026