Vulnerabilities

Vulnerability · CVE-2025-62504

Envoy is an open source edge and service proxy.

Published Oct 16, 2025 · catalog updated Oct 17, 2025 · Envoy is an open

Last checked Oct 26, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-62504. EPSS is 0.42%. Act only if a listed version of Envoy is an open is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Envoy is an open).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.42%
Remediation
Advisory link
Affected products
vendor envoyproxy envoy ≤ 1.33.11

Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connecti

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor envoyproxy envoy ≤ 1.33.11≤ 1.33.11

How to fix CVE-2025-62504

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-62504. EPSS is 0.42%. Act only if a listed version of Envoy is an open is installed.

Which versions are affected?

Compare what you have installed with envoyproxy envoy ≤ 1.33.11 ≤ 1.33.11. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.42%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 16, 2025 · EUVD

    Detected

    Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original

  2. Oct 17, 2025 · EUVD

    Updated

    Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original

Sources

  • CVE.orgVulnerability recordCVE-2025-62504

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-62504

    30-day exploitation probability 0.42%

    first.org
  • EUVDVulnerability recordEUVD-2025-34836

    Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the confi

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 26, 2026
  • CVE.orgOct 26, 2026
  • EUVDOct 26, 2026