Security fix · CVE-2025-62522
Vite is a frontend tooling framework for JavaScript.
Published Oct 20, 2025 · catalog updated Oct 20, 2025 · Vite is a frontend
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-62522. EPSS is 1.05%. Act only if a listed version of Vite is a frontend is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Vite is a frontend).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-45811 · Unknown · known exploited
- CVE-2026-39365 · Medium · known exploited
- CVE-2026-39364 · High · known exploited
- CVE-2026-39363 · High
- CVE-2025-30208 · Unknown · known exploited
- Severity
- Medium6.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.05%
- Remediation
- Version ranges on file
- Affected products
- vendor vitejs vite 3.2.9, < 4.0.0
Vite is a frontend tooling framework for JavaScript. In versions from 2.9.18 to before 3.0.0, 3.2.9 to before 4.0.0, 4.5.3 to before 5.0.0, 5.2.6 to before 5.4.21, 6.0.0 to before 6.4.1, 7.0.0 to before 7.0.8, and 7.1.0 to before 7.1.11, files denied by server.fs.deny were sent if the URL ended with \ when the dev server is running on Windows. Only apps explicitly exposing the Vite dev server to the network and running the dev server on Windows were affected. This issue has been patched in versions 5.4.21, 6.4.1, 7.0.8, and 7.1.11.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor vitejs vite 3.2.9, < 4.0.03.2.9, < 4.0.0
How to fix CVE-2025-62522
Upgrade
CVE-2025-62522 lists a fix boundary at 4.0.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 4.0.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-62522. EPSS is 1.05%. Act only if a listed version of Vite is a frontend is installed.
Which versions are affected?
Compare what you have installed with vitejs vite 3.2.9, < 4.0.0 3.2.9, < 4.0.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.05%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 20, 2025 · EUVD
Detected
Vite is a frontend tooling framework for JavaScript. In versions from 2.9.18 to before 3.0.0, 3.2.9 to before 4.0.0, 4.5.3 to before 5.0.0, 5.2.6 to before 5.4.21, 6.0.0 to before 6.4.1, 7.0.0 to before 7.0.8, and 7.1.0 to before 7.1.11, files denied by server.fs.deny were sent if the URL ended with \ when the dev server is running on Windows. Only apps explicitly exposing the Vite dev server to t
Oct 20, 2025 · EUVD
Updated
Vite is a frontend tooling framework for JavaScript. In versions from 2.9.18 to before 3.0.0, 3.2.9 to before 4.0.0, 4.5.3 to before 5.0.0, 5.2.6 to before 5.4.21, 6.0.0 to before 6.4.1, 7.0.0 to before 7.0.8, and 7.1.0 to before 7.1.11, files denied by server.fs.deny were sent if the URL ended with \ when the dev server is running on Windows. Only apps explicitly exposing the Vite dev server to t
Sources
- CVE.orgVulnerability recordCVE-2025-62522
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-62522
30-day exploitation probability 1.05%
first.org - EUVDVulnerability recordEUVD-2025-35099
Vite is a frontend tooling framework for JavaScript. In versions from 2.9.18 to before 3.0.0, 3.2.9 to before 4.0.0, 4.5.3 to before 5.0.0, 5.2.6 to before 5.4.21, 6.0.0 to before 6.4.1, 7.0.0 to before 7.0.8, and 7.1.0 to before 7.1.11, files denied by server.fs.deny were sent i
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 26, 2026
- EUVDOct 26, 2026