Vulnerabilities

Security fix · CVE-2025-62612

FastGPT is an AI Agent building platform.

Published Oct 22, 2025 · catalog updated Oct 23, 2025 · FastGPT

Last checked Oct 26, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-62612. EPSS is 0.24%. Act only if a listed version of FastGPT is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.9
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.24%
Remediation
Version ranges on file
Affected products
vendor labring FastGPT < 4.11.1

FastGPT is an AI Agent building platform. Prior to version 4.11.1, in the workflow file reading node, the network link is not security-verified, posing a risk of SSRF attacks. This issue has been patched in version 4.11.1.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor labring FastGPT < 4.11.1< 4.11.1

How to fix CVE-2025-62612

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-62612. EPSS is 0.24%. Act only if a listed version of FastGPT is installed.

Which versions are affected?

Compare what you have installed with labring FastGPT < 4.11.1 < 4.11.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.24%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 22, 2025 · EUVD

    Detected

    FastGPT is an AI Agent building platform. Prior to version 4.11.1, in the workflow file reading node, the network link is not security-verified, posing a risk of SSRF attacks. This issue has been patched in version 4.11.1.

  2. Oct 23, 2025 · EUVD

    Updated

    FastGPT is an AI Agent building platform. Prior to version 4.11.1, in the workflow file reading node, the network link is not security-verified, posing a risk of SSRF attacks. This issue has been patched in version 4.11.1.

Sources

  • CVE.orgVulnerability recordCVE-2025-62612

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-62612

    30-day exploitation probability 0.24%

    first.org
  • EUVDVulnerability recordEUVD-2025-35630

    FastGPT is an AI Agent building platform. Prior to version 4.11.1, in the workflow file reading node, the network link is not security-verified, posing a risk of SSRF attacks. This issue has been patched in version 4.11.1.

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 26, 2026
  • CVE.orgOct 26, 2026
  • EUVDOct 26, 2026