Vulnerabilities

Vulnerability · CVE-2025-62801

FastMCP is the standard framework for building MCP applications.

Published Oct 28, 2025 · catalog updated Oct 29, 2025 · FastMCP is the standard

Last checked Nov 1, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-62801. EPSS is 0.23%. Act only if a listed version of FastMCP is the standard is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (FastMCP is the standard).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.23%
Remediation
Version ranges on file
Affected products
vendor jlowin fastmcp < 2.13.0

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor jlowin fastmcp < 2.13.0< 2.13.0

How to fix CVE-2025-62801

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-62801. EPSS is 0.23%. Act only if a listed version of FastMCP is the standard is installed.

Which versions are affected?

Compare what you have installed with jlowin fastmcp < 2.13.0 < 2.13.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.23%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 28, 2025 · EUVD

    Detected

    FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

  2. Oct 29, 2025 · EUVD

    Updated

    FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

Sources

  • CVE.orgVulnerability recordCVE-2025-62801

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-62801

    30-day exploitation probability 0.23%

    first.org
  • EUVDVulnerability recordEUVD-2025-36567

    FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vu

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 1, 2026
  • CVE.orgOct 26, 2026
  • EUVDOct 26, 2026