Vulnerability · CVE-2025-63938
Tinyproxy through 1.11.2 contains an integer overflow vulnerability in the strip_return_port() function within src/reqs.c.
Published Nov 26, 2025 · catalog updated Nov 26, 2025 · Tinyproxy through 1.11.2 contains
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-63938. EPSS is 0.28%. Act only if a listed version of Tinyproxy through 1.11.2 contains is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Tinyproxy through 1.11.2 contains).
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-79589 · Critical
- CVE-2026-107024 · High
- CVE-2026-107029 · Critical
- CVE-2026-107035 · Medium
- CVE-2026-107018 · High
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.28%
- Remediation
- Vendor / distro source
- Affected products
- vendor n/a n/a n/a
Tinyproxy through 1.11.2 contains an integer overflow vulnerability in the strip_return_port() function within src/reqs.c.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor n/a n/a n/an/a
How to fix CVE-2025-63938
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-63938. EPSS is 0.28%. Act only if a listed version of Tinyproxy through 1.11.2 contains is installed.
Which versions are affected?
Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 26, 2025 · EUVD
Detected
Tinyproxy through 1.11.2 contains an integer overflow vulnerability in the strip_return_port() function within src/reqs.c.
Nov 26, 2025 · EUVD
Updated
Tinyproxy through 1.11.2 contains an integer overflow vulnerability in the strip_return_port() function within src/reqs.c.
Sources
- CVE.orgVulnerability recordCVE-2025-63938
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-63938
30-day exploitation probability 0.28%
first.org - EUVDVulnerability recordEUVD-2025-199723
Tinyproxy through 1.11.2 contains an integer overflow vulnerability in the strip_return_port() function within src/reqs.c.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026