Vulnerabilities

Vulnerability · CVE-2025-64174

Magento-lts is a long-term support alternative to Magento Community Edition (CE).

Published Nov 6, 2025 · catalog updated Nov 6, 2025 · OpenMage

Last checked Oct 31, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-64174. EPSS is 0.24%. Act only if a listed version of OpenMage is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium4.6
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.24%
Remediation
Version ranges on file
Affected products
vendor OpenMage magento-lts < 20.16.0

Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor OpenMage magento-lts < 20.16.0< 20.16.0

How to fix CVE-2025-64174

  • Upgrade

    CVE-2025-64174 lists a fix boundary at 20.16.0. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 20.16.0

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-64174. EPSS is 0.24%. Act only if a listed version of OpenMage is installed.

Which versions are affected?

Compare what you have installed with OpenMage magento-lts < 20.16.0 < 20.16.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.24%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 6, 2025 · EUVD

    Detected

    Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside ap

  2. Nov 6, 2025 · EUVD

    Updated

    Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside ap

Sources

  • CVE.orgVulnerability recordCVE-2025-64174

    Official CVE identifier

    cve.org
  • EUVDVulnerability recordEUVD-2025-37520

    Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inj

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 25, 2026
  • EUVDOct 25, 2026