Vulnerabilities

Security fix · CVE-2025-64718

js-yaml is a JavaScript YAML parser and dumper.

Published Nov 13, 2025 · catalog updated Jan 29, 2026 · js-yaml is a JavaScript

Last checked Oct 28, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-64718. EPSS is 0.42%. Act only if a listed version of js-yaml is a JavaScript is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (js-yaml is a JavaScript).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium5.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.42%
Remediation
Version ranges on file
Affected products
vendor nodeca js-yaml 4.0.0, < 4.1.1

js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution ( ). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using or (in Deno, pollution protection is on by default).

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor nodeca js-yaml 4.0.0, < 4.1.14.0.0, < 4.1.1

How to fix CVE-2025-64718

  • Upgrade

    CVE-2025-64718 lists a fix boundary at 4.1.1. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 4.1.1

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-64718. EPSS is 0.42%. Act only if a listed version of js-yaml is a JavaScript is installed.

Which versions are affected?

Compare what you have installed with nodeca js-yaml 4.0.0, < 4.1.1 4.0.0, < 4.1.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.42%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 13, 2025 · EUVD

    Detected

    js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution ( ). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using or (in Den

  2. Jan 29, 2026 · EUVD

    Updated

    js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution ( ). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using or (in Den

Sources

  • CVE.orgVulnerability recordCVE-2025-64718

    Official CVE identifier

    cve.org
  • EUVDVulnerability recordEUVD-2025-175314

    js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution ( ). All users who parse untrusted yaml documents may be impacted. The problem

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 24, 2026
  • EUVDOct 24, 2026