Security fix · CVE-2025-64762
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js.
Published Nov 21, 2025 · catalog updated Nov 24, 2025 · The AuthKit library for
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-64762. EPSS is 0.39%. Act only if a listed version of The AuthKit library for is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (The AuthKit library for).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.39%
- Remediation
- Version ranges on file
- Affected products
- vendor workos authkit-nextjs < 2.11.1
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js. In authkit-nextjs version 2.11.0 and below, authenticated responses do not defensively apply anti-caching headers. In environments where CDN caching is enabled, this can result in session tokens being included in cached responses and subsequently served to multiple users. Next.js applications deployed on Vercel are unaffected unless they manually enable CDN caching by setting cache headers on authenticated paths. Patched in authkit-nextjs 2.11.1, which appl
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor workos authkit-nextjs < 2.11.1< 2.11.1
How to fix CVE-2025-64762
Upgrade
CVE-2025-64762 lists a fix boundary at 2.11.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.11.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-64762. EPSS is 0.39%. Act only if a listed version of The AuthKit library for is installed.
Which versions are affected?
Compare what you have installed with workos authkit-nextjs < 2.11.1 < 2.11.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 21, 2025 · EUVD
Detected
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js. In authkit-nextjs version 2.11.0 and below, authenticated responses do not defensively apply anti-caching headers. In environments where CDN caching is enabled, this can result in session tokens being included in cached responses and subsequently served to mult
Nov 24, 2025 · EUVD
Updated
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js. In authkit-nextjs version 2.11.0 and below, authenticated responses do not defensively apply anti-caching headers. In environments where CDN caching is enabled, this can result in session tokens being included in cached responses and subsequently served to mult
Sources
- CVE.orgVulnerability recordCVE-2025-64762
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-64762
30-day exploitation probability 0.39%
first.org - EUVDVulnerability recordEUVD-2025-198354
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js. In authkit-nextjs version 2.11.0 and below, authenticated responses do not defensively apply anti-caching headers. In environments where CDN
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026