Vulnerability · CVE-2025-64775
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
Published Dec 1, 2025 · catalog updated Dec 1, 2025 · Apache Software Foundation Apache Struts
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-64775. EPSS is 1.53%. Act only if a listed version of Apache Software Foundation Apache Struts is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-68493 · High · known exploited
- CVE-2025-66675 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.53%
- Remediation
- Vendor / distro source
- Affected products
- vendor Apache Software Foundation Apache Struts 7.0.0 ≤7.0.3
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Apache Software Foundation Apache Struts 7.0.0 ≤7.0.37.0.0 ≤7.0.3
How to fix CVE-2025-64775
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 7.0.0 ≤7.0.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-64775. EPSS is 1.53%. Act only if a listed version of Apache Software Foundation Apache Struts is installed.
Which versions are affected?
Compare what you have installed with Apache Software Foundation Apache Struts 7.0.0 ≤7.0.3 7.0.0 ≤7.0.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.53%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Dec 1, 2025 · EUVD
Detected
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Dec 1, 2025 · EUVD
Updated
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Sources
- CVE.orgVulnerability recordCVE-2025-64775
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-64775
30-day exploitation probability 1.53%
first.org - EUVDVulnerability recordEUVD-2025-200019
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the is
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 28, 2026
- EUVDOct 27, 2026