Security fix · CVE-2025-65074
WaveView client allows users to execute restricted set of predefined commands and scripts on the connected WaveStore Server.
Published Dec 16, 2025 · catalog updated Dec 16, 2025 · WaveStore WaveStore Server
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-65074. EPSS is 0.49%. Act only if a listed version of WaveStore WaveStore Server is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-65076 · High
- CVE-2025-65075 · Medium
- Severity
- High8.6
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.49%
- Remediation
- Version ranges on file
- Affected products
- vendor WaveStore WaveStore Server 0 <6.44.44
WaveView client allows users to execute restricted set of predefined commands and scripts on the connected WaveStore Server. A malicious attacker with high-privileges is able to execute arbitrary OS commands on the server using path traversal in the showerr script. This issue was fixed in version 6.44.44
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor WaveStore WaveStore Server 0 <6.44.440 <6.44.44
How to fix CVE-2025-65074
Upgrade
CVE-2025-65074 lists a fix boundary at 6.44.44. Compare the installed build with that boundary before you change production.
Version check
Seen in 0 <6.44.44
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-65074. EPSS is 0.49%. Act only if a listed version of WaveStore WaveStore Server is installed.
Which versions are affected?
Compare what you have installed with WaveStore WaveStore Server 0 <6.44.44 0 <6.44.44. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.49%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Dec 16, 2025 · EUVD
Detected
WaveView client allows users to execute restricted set of predefined commands and scripts on the connected WaveStore Server. A malicious attacker with high-privileges is able to execute arbitrary OS commands on the server using path traversal in the showerr script. This issue was fixed in version 6.44.44
Dec 16, 2025 · EUVD
Updated
WaveView client allows users to execute restricted set of predefined commands and scripts on the connected WaveStore Server. A malicious attacker with high-privileges is able to execute arbitrary OS commands on the server using path traversal in the showerr script. This issue was fixed in version 6.44.44
Sources
- CVE.orgVulnerability recordCVE-2025-65074
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-65074
30-day exploitation probability 0.49%
first.org - EUVDVulnerability recordEUVD-2025-203628
WaveView client allows users to execute restricted set of predefined commands and scripts on the connected WaveStore Server. A malicious attacker with high-privileges is able to execute arbitrary OS commands on the server using path traversal in the showerr script. This issue was
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgNov 2, 2026
- EUVDNov 1, 2026