Vulnerabilities

Vulnerability · CVE-2025-65106

LangChain is a framework for building agents and LLM-powered applications.

Published Nov 21, 2025 · catalog updated Nov 21, 2025 · LangChain is a framework

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-65106. EPSS is 0.52%. Act only if a listed version of LangChain is a framework is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (LangChain is a framework).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.52%
Remediation
Version ranges on file
Affected products
vendor langchain-ai langchain < 0.3.80

LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor langchain-ai langchain < 0.3.80< 0.3.80

How to fix CVE-2025-65106

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-65106. EPSS is 0.52%. Act only if a listed version of LangChain is a framework is installed.

Which versions are affected?

Compare what you have installed with langchain-ai langchain < 0.3.80 < 0.3.80. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.52%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 21, 2025 · EUVD

    Detected

    LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in C

  2. Nov 21, 2025 · EUVD

    Updated

    LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in C

Sources

  • CVE.orgVulnerability recordCVE-2025-65106

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-65106

    30-day exploitation probability 0.52%

    first.org
  • EUVDVulnerability recordEUVD-2025-198318

    LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template s

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 29, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 28, 2026