Threat intelligence · CVE-2025-65107
Langfuse is an open source large language model engineering platform.
Published Nov 21, 2025 · catalog updated Nov 24, 2025 · Langfuse
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-65107. EPSS is 0.17%. Act only if a listed version of Langfuse is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-64504 · Medium
- CVE-2025-9799 · Low
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.17%
- Remediation
- Version ranges on file
- Affected products
- vendor langfuse Langfuse 3.17.0, < 3.131.0
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_ _CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_ _CHECK.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor langfuse Langfuse 3.17.0, < 3.131.03.17.0, < 3.131.0
How to fix CVE-2025-65107
Upgrade
CVE-2025-65107 lists a fix boundary at 3.131.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.131.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-65107. EPSS is 0.17%. Act only if a listed version of Langfuse is installed.
Which versions are affected?
Compare what you have installed with langfuse Langfuse 3.17.0, < 3.131.0 3.17.0, < 3.131.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.17%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 21, 2025 · EUVD
Detected
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_ _CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2
Nov 24, 2025 · EUVD
Updated
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_ _CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2
Sources
- CVE.orgVulnerability recordCVE-2025-65107
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-65107
30-day exploitation probability 0.17%
first.org - EUVDVulnerability recordEUVD-2025-198512
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_ _CHECK setting, a potential account takeover may happen if an authenticated
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 7, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026