Vulnerability · CVE-2025-65199
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root
Published Dec 10, 2025 · catalog updated Dec 18, 2025 · Windscribe Windscribe for Linux Desktop App
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-65199. EPSS is 1.25%. Act only if a listed version of Windscribe Windscribe for Linux Desktop App is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.25%
- Remediation
- Version ranges on file
- Affected products
- vendor Windscribe Windscribe for Linux Desktop App 2.10.1 <2.18.8
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Windscribe Windscribe for Linux Desktop App 2.10.1 <2.18.82.10.1 <2.18.8
How to fix CVE-2025-65199
Upgrade
CVE-2025-65199 lists a fix boundary at 2.18.8. Compare the installed build with that boundary before you change production.
Version check
Seen in 2.10.1 <2.18.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-65199. EPSS is 1.25%. Act only if a listed version of Windscribe Windscribe for Linux Desktop App is installed.
Which versions are affected?
Compare what you have installed with Windscribe Windscribe for Linux Desktop App 2.10.1 <2.18.8 2.10.1 <2.18.8. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.25%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 10, 2025 · EUVD
Detected
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
Dec 18, 2025 · EUVD
Updated
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
Sources
- CVE.orgVulnerability recordCVE-2025-65199
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-65199
30-day exploitation probability 1.25%
first.org - EUVDVulnerability recordEUVD-2025-202584
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgOct 27, 2026
- EUVDOct 27, 2026