Vulnerabilities

Vulnerability · CVE-2025-65622

Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session

Published Dec 1, 2025 · catalog updated Jul 5, 2026 · Snipe-IT before 8.3.4 allows

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-65622. EPSS is 0.20%. Act only if a listed version of Snipe-IT before 8.3.4 allows is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Snipe-IT before 8.3.4 allows).
  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.20%
Remediation
Vendor / distro source
Affected products
vendor n/a n/a n/a

Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor n/a n/a n/an/a

How to fix CVE-2025-65622

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-65622. EPSS is 0.20%. Act only if a listed version of Snipe-IT before 8.3.4 allows is installed.

Which versions are affected?

Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.20%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 1, 2025 · EUVD

    Detected

    Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.

  2. Jul 5, 2026 · EUVD

    Updated

    Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.

Sources

  • CVE.orgVulnerability recordCVE-2025-65622

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-65622

    30-day exploitation probability 0.20%

    first.org
  • EUVDVulnerability recordEUVD-2025-200077

    Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 4, 2026
  • CVE.orgOct 26, 2026
  • EUVDOct 26, 2026