Vulnerability · CVE-2025-66205
Frappe is a full-stack web application framework.
Published Dec 1, 2025 · catalog updated Dec 1, 2025 · Frappe is a full-stack
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66205. EPSS is 0.31%. Act only if a listed version of Frappe is a full-stack is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Frappe is a full-stack).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-111388 · Medium
- CVE-2026-3837 · Medium
- CVE-2026-3673 · Medium
- CVE-2026-39351 · Medium
- CVE-2026-35614 · Critical
- Severity
- High7.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.31%
- Remediation
- Version ranges on file
- Affected products
- vendor frappe frappe < 14.99.2
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor frappe frappe < 14.99.2< 14.99.2
How to fix CVE-2025-66205
Upgrade
CVE-2025-66205 lists a fix boundary at 14.99.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 14.99.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66205. EPSS is 0.31%. Act only if a listed version of Frappe is a full-stack is installed.
Which versions are affected?
Compare what you have installed with frappe frappe < 14.99.2 < 14.99.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.31%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 1, 2025 · EUVD
Detected
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.
Dec 1, 2025 · EUVD
Updated
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.
Sources
- CVE.orgVulnerability recordCVE-2025-66205
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66205
30-day exploitation probability 0.31%
first.org - EUVDVulnerability recordEUVD-2025-200084
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- EUVDOct 27, 2026