Vulnerabilities

Vulnerability · CVE-2025-66217

AIS-catcher is a multi-platform AIS receiver.

Published Nov 29, 2025 · catalog updated Dec 1, 2025 · AIS-catcher

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-66217. EPSS is 0.78%. Act only if a listed version of AIS-catcher is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.78%
Remediation
Version ranges on file
Affected products
vendor jvde-github AIS-catcher < 0.64

AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory Corruption that can be leveraged for Remote Code Execution (RCE). This issue has been patched in version 0.64.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor jvde-github AIS-catcher < 0.64< 0.64

How to fix CVE-2025-66217

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-66217. EPSS is 0.78%. Act only if a listed version of AIS-catcher is installed.

Which versions are affected?

Compare what you have installed with jvde-github AIS-catcher < 0.64 < 0.64. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.78%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 29, 2025 · EUVD

    Detected

    AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory

  2. Dec 1, 2025 · EUVD

    Updated

    AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory

Sources

  • CVE.orgVulnerability recordCVE-2025-66217

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-66217

    30-day exploitation probability 0.78%

    first.org
  • EUVDVulnerability recordEUVD-2025-199900

    AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manip

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 2, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 28, 2026