Vulnerabilities

Vulnerability · CVE-2025-66388

A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secret

Published Dec 15, 2025 · catalog updated Dec 16, 2025 · Apache Software Foundation Apache Airflow

Last checked Oct 27, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-66388. EPSS is 0.48%. Act only if a listed version of Apache Software Foundation Apache Airflow is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium4.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.48%
Remediation
Version ranges on file
Affected products
vendor Apache Software Foundation Apache Airflow 3.1.0 <3.1.4

A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Apache Software Foundation Apache Airflow 3.1.0 <3.1.43.1.0 <3.1.4

How to fix CVE-2025-66388

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-66388. EPSS is 0.48%. Act only if a listed version of Apache Software Foundation Apache Airflow is installed.

Which versions are affected?

Compare what you have installed with Apache Software Foundation Apache Airflow 3.1.0 <3.1.4 3.1.0 <3.1.4. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.48%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 15, 2025 · EUVD

    Detected

    A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.

  2. Dec 16, 2025 · EUVD

    Updated

    A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.

Sources

  • CVE.orgVulnerability recordCVE-2025-66388

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-66388

    30-day exploitation probability 0.48%

    first.org
  • EUVDVulnerability recordEUVD-2025-203358

    A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4,

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 27, 2026
  • FIRST EPSSOct 27, 2026
  • EUVDOct 27, 2026