Vulnerability · CVE-2025-66470
NiceGUI is a Python-based UI framework.
Published Dec 9, 2025 · catalog updated Dec 9, 2025 · NiceGUI is a Python-based
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66470. EPSS is 0.25%. Act only if a listed version of NiceGUI is a Python-based is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (NiceGUI is a Python-based).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-39844 · High
- CVE-2026-33332 · Medium
- CVE-2026-27156 · Medium
- CVE-2026-21874 · Medium
- CVE-2026-21873 · High
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.25%
- Remediation
- Version ranges on file
- Affected products
- vendor zauberzeug nicegui < 3.4.0
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG tag whenever the image component is rendered or updated. This is particularly dangerous for dashboards or multi-user applications displaying user-generated content or annotations. This issue is fixed in version 3.4.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor zauberzeug nicegui < 3.4.0< 3.4.0
How to fix CVE-2025-66470
Upgrade
CVE-2025-66470 lists a fix boundary at 3.4.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.4.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66470. EPSS is 0.25%. Act only if a listed version of NiceGUI is a Python-based is installed.
Which versions are affected?
Compare what you have installed with zauberzeug nicegui < 3.4.0 < 3.4.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.25%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 9, 2025 · EUVD
Detected
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG tag whenever the image component is rendered or updated. This is particularly dange
Dec 9, 2025 · EUVD
Updated
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG tag whenever the image component is rendered or updated. This is particularly dange
Sources
- CVE.orgVulnerability recordCVE-2025-66470
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66470
30-day exploitation probability 0.25%
first.org - EUVDVulnerability recordEUVD-2025-201813
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject mali
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgOct 27, 2026
- EUVDOct 27, 2026