Vulnerability · CVE-2025-66566
yawkat LZ4 Java provides LZ4 compression for Java.
Published Dec 5, 2025 · catalog updated Dec 5, 2025 · yawkat LZ4 Java provides
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66566. EPSS is 0.60%. Act only if a listed version of yawkat LZ4 Java provides is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (yawkat LZ4 Java provides).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.2
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.60%
- Remediation
- Version ranges on file
- Affected products
- vendor yawkat lz4-java < 1.10.1
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor yawkat lz4-java < 1.10.1< 1.10.1
How to fix CVE-2025-66566
Upgrade
CVE-2025-66566 lists a fix boundary at 1.10.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.10.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66566. EPSS is 0.60%. Act only if a listed version of yawkat LZ4 Java provides is installed.
Which versions are affected?
Compare what you have installed with yawkat lz4-java < 1.10.1 < 1.10.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.60%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 5, 2025 · EUVD
Detected
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations
Dec 5, 2025 · EUVD
Updated
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations
Sources
- CVE.orgVulnerability recordCVE-2025-66566
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66566
30-day exploitation probability 0.60%
first.org - EUVDVulnerability recordEUVD-2025-201456
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- CVE.orgOct 28, 2026
- EUVDOct 27, 2026