Vulnerability · CVE-2025-66614
Improper Input Validation vulnerability.
Published Feb 17, 2026 · catalog updated Jun 17, 2026 · Improper Input Validation vulnerability.
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66614. EPSS is 0.27%. Act only if a listed version of Improper Input Validation vulnerability. is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Improper Input Validation vulnerability.).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/tomcat
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/tomcat9.0.0
- cpe apache/tomcat< 10.1.50
- cpe apache/tomcat< 11.0.15
- cpe apache/tomcat< 9.0.113
How to fix CVE-2025-66614
Upgrade
CVE-2025-66614 lists a fix boundary at 10.1.50. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.1.50
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66614. EPSS is 0.27%. Act only if a listed version of Improper Input Validation vulnerability. is installed.
Which versions are affected?
Compare what you have installed with 9.0.0, < 10.1.50, < 11.0.15, < 9.0.113. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation; CWE-295: Improper Certificate Validation. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 17, 2026 · Monitored products — critical
Detected
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension wa
Jun 17, 2026 · Monitored products — critical
Updated
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension wa
Sources
- CVE.orgVulnerability recordCVE-2025-66614
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2025-66614
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension wa
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026