Vulnerabilities

Security fix · CVE-2025-67490

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications.

Published Dec 10, 2025 · catalog updated Dec 11, 2025 · The Auth0 Next.js SDK

Last checked Oct 30, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-67490. EPSS is 0.20%. Act only if a listed version of The Auth0 Next.js SDK is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (The Auth0 Next.js SDK).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.20%
Remediation
Version ranges on file
Affected products
vendor auth0 nextjs-auth0 4.12.0, < 4.12.1

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor auth0 nextjs-auth0 4.12.0, < 4.12.14.12.0, < 4.12.1

How to fix CVE-2025-67490

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-67490. EPSS is 0.20%. Act only if a listed version of The Auth0 Next.js SDK is installed.

Which versions are affected?

Compare what you have installed with auth0 nextjs-auth0 4.12.0, < 4.12.1 4.12.0, < 4.12.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.20%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 10, 2025 · EUVD

    Detected

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

  2. Dec 11, 2025 · EUVD

    Updated

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

Sources

  • CVE.orgVulnerability recordCVE-2025-67490

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-67490

    30-day exploitation probability 0.20%

    first.org
  • EUVDVulnerability recordEUVD-2025-202631

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This is

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 30, 2026
  • CVE.orgOct 27, 2026
  • EUVDOct 27, 2026