Security fix · CVE-2025-67731
Servify Express is a Node.js package to start an Express server and log the port it's running on.
Published Dec 12, 2025 · catalog updated Dec 12, 2025 · Aarondoran
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-67731. EPSS is 0.40%. Act only if a listed version of Aarondoran is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.40%
- Remediation
- Version ranges on file
- Affected products
- vendor Aarondoran servify-express < 1.2
Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected. The issue is not a flaw in Express itself, but in configuration. This issue is fixed in version 1.2. To work around, consider adding a limi
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Aarondoran servify-express < 1.2< 1.2
How to fix CVE-2025-67731
Upgrade
CVE-2025-67731 lists a fix boundary at 1.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-67731. EPSS is 0.40%. Act only if a listed version of Aarondoran is installed.
Which versions are affected?
Compare what you have installed with Aarondoran servify-express < 1.2 < 1.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.40%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 12, 2025 · EUVD
Detected
Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser
Dec 12, 2025 · EUVD
Updated
Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser
Sources
- CVE.orgVulnerability recordCVE-2025-67731
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-67731
30-day exploitation probability 0.40%
first.org - EUVDVulnerability recordEUVD-2025-202768
Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage,
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgOct 27, 2026
- EUVDOct 27, 2026