Vulnerabilities

Security fix · CVE-2025-67746

Composer is a dependency manager for PHP.

Published Dec 30, 2025 · catalog updated Dec 30, 2025 · Composer is a dependency

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-67746. EPSS is 0.45%. Act only if a listed version of Composer is a dependency is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Composer is a dependency).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Low1.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.45%
Remediation
Version ranges on file
Affected products
vendor composer composer 2.3, < 2.9.3

Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor composer composer 2.3, < 2.9.32.3, < 2.9.3

How to fix CVE-2025-67746

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-67746. EPSS is 0.45%. Act only if a listed version of Composer is a dependency is installed.

Which versions are affected?

Compare what you have installed with composer composer 2.3, < 2.9.3 2.3, < 2.9.3. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.45%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 30, 2025 · EUVD

    Detected

    Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this h

  2. Dec 30, 2025 · EUVD

    Updated

    Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this h

Sources

  • CVE.orgVulnerability recordCVE-2025-67746

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-67746

    30-day exploitation probability 0.45%

    first.org
  • EUVDVulnerability recordEUVD-2025-205815

    Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangl

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 2, 2026
  • CVE.orgNov 2, 2026
  • EUVDNov 1, 2026