Vulnerabilities

Vulnerability · CVE-2025-67896

Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures

Published Dec 14, 2025 · catalog updated Oct 14, 2026 · Exim before 4.99.1, with

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-67896. EPSS is 0.47%. Act only if a listed version of Exim before 4.99.1, with is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Exim before 4.99.1, with).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.47%
Remediation
Version ranges on file
Affected products
cpe exim/exim · vendor exim exim 4.99 <4.99.1

Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe exim/eximversion unspecified
  • vendor exim exim 4.99 <4.99.14.99 <4.99.1

How to fix CVE-2025-67896

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-67896. EPSS is 0.47%. Act only if a listed version of Exim before 4.99.1, with is installed.

Which versions are affected?

Compare what you have installed with exim exim 4.99 <4.99.1 4.99 <4.99.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-122: Heap-based Buffer Overflow. EPSS 0.47%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 14, 2025 · NIST NVD

    Detected

    Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

  2. Oct 14, 2026 · NIST NVD

    Updated

    Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

Sources

  • CVE.orgVulnerability recordCVE-2025-67896

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-67896

    30-day exploitation probability 0.47%

    first.org
  • EUVDVulnerability recordEUVD-2025-203281

    Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

    euvd.enisa.europa.eu
  • NIST NVDVulnerability recordCVE-2025-67896

    Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • EUVDOct 27, 2026
  • FIRST EPSSOct 23, 2026
  • CVE.orgOct 16, 2026
  • NIST NVDOct 14, 2026