Vulnerability · CVE-2025-67901
openrsync through 0.5.0, as used in OpenBSD through 7.8 and on other platforms, allows a client to cause a server SIGSEGV by specifying a length of zero for block data, because the
Published Dec 14, 2025 · catalog updated Dec 15, 2025 · openrsync through 0.5.0, as
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-67901. EPSS is 0.28%. Act only if a listed version of openrsync through 0.5.0, as is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (openrsync through 0.5.0, as).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.28%
- Remediation
- Vendor / distro source
- Affected products
- vendor kristapsdz openrsync 0 ≤0.5.0
openrsync through 0.5.0, as used in OpenBSD through 7.8 and on other platforms, allows a client to cause a server SIGSEGV by specifying a length of zero for block data, because the relationship between p->rem and p->len is not checked.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor kristapsdz openrsync 0 ≤0.5.00 ≤0.5.0
How to fix CVE-2025-67901
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 0 ≤0.5.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-67901. EPSS is 0.28%. Act only if a listed version of openrsync through 0.5.0, as is installed.
Which versions are affected?
Compare what you have installed with kristapsdz openrsync 0 ≤0.5.0 0 ≤0.5.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 14, 2025 · EUVD
Detected
openrsync through 0.5.0, as used in OpenBSD through 7.8 and on other platforms, allows a client to cause a server SIGSEGV by specifying a length of zero for block data, because the relationship between p->rem and p->len is not checked.
Dec 15, 2025 · EUVD
Updated
openrsync through 0.5.0, as used in OpenBSD through 7.8 and on other platforms, allows a client to cause a server SIGSEGV by specifying a length of zero for block data, because the relationship between p->rem and p->len is not checked.
Sources
- CVE.orgVulnerability recordCVE-2025-67901
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-67901
30-day exploitation probability 0.28%
first.org - EUVDVulnerability recordEUVD-2025-203316
openrsync through 0.5.0, as used in OpenBSD through 7.8 and on other platforms, allows a client to cause a server SIGSEGV by specifying a length of zero for block data, because the relationship between p->rem and p->len is not checked.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 5, 2026
- CVE.orgOct 27, 2026
- EUVDOct 27, 2026