Vulnerabilities

Security fix · CVE-2025-68614

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool.

Published Dec 22, 2025 · catalog updated Dec 22, 2025 · LibreNMS is an auto-discovering

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-68614. EPSS is 3.88%. Act only if a listed version of LibreNMS is an auto-discovering is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (LibreNMS is an auto-discovering).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium4.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
3.88%
Remediation
Version ranges on file
Affected products
vendor librenms librenms < 25.12.0

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor librenms librenms < 25.12.0< 25.12.0

How to fix CVE-2025-68614

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-68614. EPSS is 3.88%. Act only if a listed version of LibreNMS is an auto-discovering is installed.

Which versions are affected?

Compare what you have installed with librenms librenms < 25.12.0 < 25.12.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 3.88%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 22, 2025 · EUVD

    Detected

    LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.

  2. Dec 22, 2025 · EUVD

    Updated

    LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.

Sources

  • CVE.orgVulnerability recordCVE-2025-68614

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-68614

    30-day exploitation probability 3.88%

    first.org
  • EUVDVulnerability recordEUVD-2025-204770

    LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 2, 2026
  • CVE.orgNov 2, 2026
  • EUVDNov 1, 2026