Security fix · CVE-2025-68615
net-snmp is a SNMP application library, tools and daemon.
Published Dec 22, 2025 · catalog updated May 1, 2026 · net-snmp is a SNMP
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2025-68615 is not in CISA KEV. FIRST estimates a 42.36% chance of exploitation in the next 30 days. Check whether you run net-snmp is a SNMP.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (net-snmp is a SNMP).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 42.36%
- Remediation
- Version ranges on file
- Affected products
- vendor net-snmp net-snmp 5.10.pre1, < 5.10.pre2
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor net-snmp net-snmp 5.10.pre1, < 5.10.pre25.10.pre1, < 5.10.pre2
How to fix CVE-2025-68615
Upgrade
CVE-2025-68615 lists a fix boundary at 5.10.pre2. Compare the installed build with that boundary before you change production.
Version check
Affected < 5.10.pre2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2025-68615 is not in CISA KEV. FIRST estimates a 42.36% chance of exploitation in the next 30 days. Check whether you run net-snmp is a SNMP.
Which versions are affected?
Compare what you have installed with net-snmp net-snmp 5.10.pre1, < 5.10.pre2 5.10.pre1, < 5.10.pre2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 42.36%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 22, 2025 · EUVD
Detected
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
May 1, 2026 · EUVD
Updated
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Sources
- CVE.orgVulnerability recordCVE-2025-68615
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-68615
30-day exploitation probability 42.36%
first.org - EUVDVulnerability recordEUVD-2025-204779
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- CVE.orgOct 29, 2026
- EUVDOct 29, 2026