Vulnerability · CVE-2025-68659
Discourse is an open source discussion platform.
Published Jan 28, 2026 · catalog updated Jan 28, 2026 · Discourse is an open
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-68659. EPSS is 0.26%. Act only if a listed version of Discourse is an open is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Discourse is an open).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-91157 · High
- CVE-2026-91156 · High
- CVE-2026-91159 · High
- CVE-2026-34154 · Low
- CVE-2026-33514 · Medium
- Severity
- Medium4.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.26%
- Remediation
- Version ranges on file
- Affected products
- vendor discourse discourse 2026.1.0-latest, < 2026.1.0
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor discourse discourse 2026.1.0-latest, < 2026.1.02026.1.0-latest, < 2026.1.0
How to fix CVE-2025-68659
Upgrade
CVE-2025-68659 lists a fix boundary at 2026.1.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 2026.1.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-68659. EPSS is 0.26%. Act only if a listed version of Discourse is an open is installed.
Which versions are affected?
Compare what you have installed with discourse discourse 2026.1.0-latest, < 2026.1.0 2026.1.0-latest, < 2026.1.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.26%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 28, 2026 · EUVD
Detected
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//prefere
Jan 28, 2026 · EUVD
Updated
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//prefere
Sources
- CVE.orgVulnerability recordCVE-2025-68659
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-68659
30-day exploitation probability 0.26%
first.org - EUVDVulnerability recordEUVD-2025-206425
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- CVE.orgNov 4, 2026
- EUVDNov 4, 2026