Vulnerability · CVE-2025-68675
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information.
Published Jan 16, 2026 · catalog updated Nov 3, 2026 · In Apache Airflow versions
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-68675. EPSS is 1.88%. Act only if a listed version of In Apache Airflow versions is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Apache Airflow versions).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.88%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow · vendor Apache Software Foundation Apache Airflow 3.0.0 <3.1.6
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed. Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow< 3.1.6
- vendor Apache Software Foundation Apache Airflow 3.0.0 <3.1.63.0.0 <3.1.6
How to fix CVE-2025-68675
Upgrade
CVE-2025-68675 lists a fix boundary at 3.1.6. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.1.6
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-68675. EPSS is 1.88%. Act only if a listed version of In Apache Airflow versions is installed.
Which versions are affected?
Compare what you have installed with Apache Software Foundation Apache Airflow 3.0.0 <3.1.6 3.0.0 <3.1.6. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-532: Insertion of Sensitive Information into Log File. EPSS 1.88%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 16, 2026 · Monitored products — high
Detected
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields coul
Jun 17, 2026 · Monitored products — high
Updated
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields coul
Nov 3, 2026 · NIST NVD
Updated
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields coul
Sources
- EUVDVulnerability recordEUVD-2026-2912
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log out
euvd.enisa.europa.eu - Monitored products — highVendor advisoryCVE-2025-68675
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields coul
nvd.nist.gov - NIST NVDVulnerability recordCVE-2025-68675
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log out
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- NIST NVDNov 3, 2026
- EUVDNov 2, 2026
- Monitored products — highNov 2, 2026