Vulnerability · CVE-2025-68931
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries.
Published Jan 13, 2026 · catalog updated Jan 13, 2026 · Jervis is a library
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-68931. EPSS is 0.20%. Act only if a listed version of Jervis is a library is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Jervis is a library).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-68925 · Medium
- CVE-2025-68704 · High
- CVE-2025-68703 · High
- CVE-2025-68702 · High
- CVE-2025-68701 · High
- Severity
- High8.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.20%
- Remediation
- Version ranges on file
- Affected products
- vendor samrocketman jervis < 2.2
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, AES/CBC/PKCS5Padding lacks authentication, making it vulnerable to padding oracle attacks and ciphertext manipulation. This vulnerability is fixed in 2.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor samrocketman jervis < 2.2< 2.2
How to fix CVE-2025-68931
Upgrade
CVE-2025-68931 lists a fix boundary at 2.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-68931. EPSS is 0.20%. Act only if a listed version of Jervis is a library is installed.
Which versions are affected?
Compare what you have installed with samrocketman jervis < 2.2 < 2.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.20%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 13, 2026 · EUVD
Detected
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, AES/CBC/PKCS5Padding lacks authentication, making it vulnerable to padding oracle attacks and ciphertext manipulation. This vulnerability is fixed in 2.2.
Jan 13, 2026 · EUVD
Updated
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, AES/CBC/PKCS5Padding lacks authentication, making it vulnerable to padding oracle attacks and ciphertext manipulation. This vulnerability is fixed in 2.2.
Sources
- CVE.orgVulnerability recordCVE-2025-68931
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-68931
30-day exploitation probability 0.20%
first.org - EUVDVulnerability recordEUVD-2026-2022
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, AES/CBC/PKCS5Padding lacks authentication, making it vulnerable to padding oracle attacks and ciphertext manipulation. This vulnerability is fixed in 2.2.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 31, 2026
- CVE.orgOct 30, 2026
- EUVDOct 30, 2026