Vulnerabilities

Vulnerability · CVE-2025-69289

Discourse is an open source discussion platform.

Published Jan 28, 2026 · catalog updated Jan 28, 2026 · Discourse is an open

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-69289. EPSS is 0.19%. Act only if a listed version of Discourse is an open is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Discourse is an open).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.19%
Remediation
Version ranges on file
Affected products
vendor discourse discourse 2026.1.0-latest, < 2026.1.0

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor discourse discourse 2026.1.0-latest, < 2026.1.02026.1.0-latest, < 2026.1.0

How to fix CVE-2025-69289

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-69289. EPSS is 0.19%. Act only if a listed version of Discourse is an open is installed.

Which versions are affected?

Compare what you have installed with discourse discourse 2026.1.0-latest, < 2026.1.0 2026.1.0-latest, < 2026.1.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.19%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 28, 2026 · EUVD

    Detected

    Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "req

  2. Jan 28, 2026 · EUVD

    Updated

    Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "req

Sources

  • CVE.orgVulnerability recordCVE-2025-69289

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-69289

    30-day exploitation probability 0.19%

    first.org
  • EUVDVulnerability recordEUVD-2025-206430

    Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 4, 2026
  • CVE.orgNov 4, 2026
  • EUVDNov 4, 2026