Vulnerabilities

Vulnerability · CVE-2025-9353

The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input s

Published Sep 24, 2025 · catalog updated Apr 8, 2026 · Themify Builder

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-9353. EPSS is 0.33%. Act only if a listed version of Themify Builder is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.33%
Remediation
Vendor / distro source
Affected products
vendor themifyme Themify Builder 0 ≤7.6.9

The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor themifyme Themify Builder 0 ≤7.6.90 ≤7.6.9

How to fix CVE-2025-9353

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-9353. EPSS is 0.33%. Act only if a listed version of Themify Builder is installed.

Which versions are affected?

Compare what you have installed with themifyme Themify Builder 0 ≤7.6.9 0 ≤7.6.9. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 24, 2025 · EUVD

    Detected

    The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injecte

  2. Apr 8, 2026 · EUVD

    Updated

    The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injecte

Sources

  • CVE.orgVulnerability recordCVE-2025-9353

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-9353

    30-day exploitation probability 0.33%

    first.org
  • EUVDVulnerability recordEUVD-2025-30960

    The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributo

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 23, 2026
  • FIRST EPSSOct 23, 2026
  • EUVDOct 22, 2026