Vulnerability · CVE-2025-9803
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration.
Published Nov 25, 2025 · catalog updated Nov 25, 2025 · lunary-ai/lunary version 1.9.34 is
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-9803. EPSS is 0.46%. Act only if a listed version of lunary-ai/lunary version 1.9.34 is is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (lunary-ai/lunary version 1.9.34 is).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-5352 · High
- CVE-2025-4962 · High
- CVE-2025-4779 · Critical
- Severity
- Critical9.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.46%
- Remediation
- Version ranges on file
- Affected products
- vendor lunary-ai lunary-ai/lunary unspecified <1.9.35
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthorized access to user accounts. The issue is resolved in version 1.9.35.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor lunary-ai lunary-ai/lunary unspecified <1.9.35unspecified <1.9.35
How to fix CVE-2025-9803
Upgrade
CVE-2025-9803 lists a fix boundary at 1.9.35. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <1.9.35
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-9803. EPSS is 0.46%. Act only if a listed version of lunary-ai/lunary version 1.9.34 is is installed.
Which versions are affected?
Compare what you have installed with lunary-ai lunary-ai/lunary unspecified <1.9.35 unspecified <1.9.35. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 25, 2025 · EUVD
Detected
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthoriz
Nov 25, 2025 · EUVD
Updated
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthoriz
Sources
- CVE.orgVulnerability recordCVE-2025-9803
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-9803
30-day exploitation probability 0.46%
first.org - EUVDVulnerability recordEUVD-2025-199529
lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intende
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026