Vulnerability · CVE-2026-0969
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content.
Published Feb 12, 2026 · catalog updated Apr 17, 2026 · Hashicorp Shared library
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-0969. EPSS is 0.65%. Act only if a listed version of Hashicorp Shared library is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-8959 · High
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.65%
- Remediation
- Version ranges on file
- Affected products
- vendor Hashicorp Shared library 4.3.0 <6.0.0
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Hashicorp Shared library 4.3.0 <6.0.04.3.0 <6.0.0
How to fix CVE-2026-0969
Upgrade
CVE-2026-0969 lists a fix boundary at 6.0.0. Compare the installed build with that boundary before you change production.
Version check
Seen in 4.3.0 <6.0.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-0969. EPSS is 0.65%. Act only if a listed version of Hashicorp Shared library is installed.
Which versions are affected?
Compare what you have installed with Hashicorp Shared library 4.3.0 <6.0.0 4.3.0 <6.0.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.65%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 12, 2026 · EUVD
Detected
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
Apr 17, 2026 · EUVD
Updated
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
Sources
- CVE.orgVulnerability recordCVE-2026-0969
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-0969
30-day exploitation probability 0.65%
first.org - EUVDVulnerability recordEUVD-2026-7026
The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- FIRST EPSSNov 3, 2026
- EUVDNov 2, 2026