Security fix · CVE-2026-106457
Backstage is an open framework for building developer portals.
Published Oct 6, 2026 · catalog updated Oct 27, 2026 · Backstage is an open
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-106457. EPSS is 0.28%. Act only if a listed version of Backstage is an open is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Backstage is an open).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.28%
- Remediation
- Version ranges on file
- Affected products
- cpe linuxfoundation/backstage · cpe linuxfoundation/backstage/plugin-auth-backend-module-cloudflare-access-provider
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream. Cloudflare Access normally evaluates the protected application before forwarding requests. This issue is fixed in version 0.5.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe linuxfoundation/backstage< 1.55.0
- cpe linuxfoundation/backstage/plugin-auth-backend-module-cloudflare-access-provider< 0.5.0
How to fix CVE-2026-106457
Upgrade
CVE-2026-106457 lists a fix boundary at 1.55.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.55.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-106457. EPSS is 0.28%. Act only if a listed version of Backstage is an open is installed.
Which versions are affected?
Compare what you have installed with < 1.55.0, < 0.5.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-287: Improper Authentication. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 6, 2026 · NIST NVD
Detected
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for
Oct 27, 2026 · NIST NVD
Updated
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for
Sources
- CVE.orgVulnerability recordCVE-2026-106457
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-106457
30-day exploitation probability 0.28%
first.org - NIST NVDVulnerability recordCVE-2026-106457
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth p
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- NIST NVDOct 28, 2026