Vulnerability · CVE-2026-107588
Cross-site Scripting (XSS)
Published Oct 21, 2026 · catalog updated Oct 22, 2026 · Cross-site Scripting (XSS)
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-107588. EPSS is 0.52%. Act only if a listed version of Cross-site Scripting (XSS) is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Cross-site Scripting (XSS)).
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.52%
- Remediation
- Advisory link
- Affected products
- package maven · package npm
Vaadin Charts renders charts with the Highcharts library and pins an exact version of it, 9.2.2 in Vaadin 22 to 24 and 12.2.0 in Vaadin 25, so an application cannot remove these vulnerabilities by upgrading Highcharts on its own. Highsoft disclosed several vulnerabilities in that library that are reachable through the chart configuration: writes to Object.prototype through dotted series.keys paths, and cross-site scripting through credits.href, through breadcrumbs.style, through HTML text parsing while printing, and through xlink:href attributes in exported charts. An application is affected where data an attacker controls reaches the chart configuration, for example through additionalOptions, through updateConfiguration(), or through text options that accept markup. The fixed Vaadin versions apply Highsoft's recommended workarounds to the bundled Highcharts when it loads, and keep the same Highcharts version. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 22.0.0 - 23.6.15 Vaadin 24.0.0 - 24.4.23 Vaadin 24.5.0 - 24.7.15 Vaadin 24.8.0 - 24.9.22 Vaadin 24.10.0 - 24.10.10 Vaadin 25.0.0 - 25.2.9 Vaadin 25.3.0 Mitigation Upgrade to 23.6.16 Upgrade to 24.4.24 Upgrade to 24.7.16 Upgrade to 24.9.23 Upgrade to 24.10.11 Upgrade to 25.2.10 Upgrade to 25.3.1 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, 25 version. Artifacts Maven coordinates / Vulnerable versions / Fixed version com.vaadin:vaadin / 22.0.0 - 23.6.15 / >=23.6.16 com.vaadin:vaadin / 24.0.0 - 24.4.23 / >=24.4.24 com.vaadin:vaadin / 24.5.0 - 24.7.15 / >=24.7.16 com.vaadin:vaadin / 24.8.0 - 24.9.22 / >=24.9.23 com.vaadin:vaadin / 24.10.0 - 24.10.10 / >=24.10.11 com.vaadin:vaadin / 25.0.0 - 25.0.13 / >=25.2.10 com.vaadin:vaadin / 25.1.0 - 25.1.13 / >=25.2.10 com.vaadin:vaadin / 25.2.0 - 25.2.9 / >=25.2.10 com.vaadin:vaadin / 25.3.0 / >
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- package mavenversion unspecified
- package npmversion unspecified
How to fix CVE-2026-107588
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-107588. EPSS is 0.52%. Act only if a listed version of Cross-site Scripting (XSS) is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-1321: Improperly Controlled Modification of Object Prototype Attributes (Prototype Pollution); CWE-79: Cross-site Scripting (XSS). EPSS 0.52%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 21, 2026 · NIST NVD
Detected
Vaadin Charts renders charts with the Highcharts library and pins an exact version of it, 9.2.2 in Vaadin 22 to 24 and 12.2.0 in Vaadin 25, so an application cannot remove these vulnerabilities by upgrading Highcharts on its own. Highsoft disclosed several vulnerabilities in that library that are reachable through the chart configuration: writes to Object.prototype through dotted series.keys paths
Oct 22, 2026 · NIST NVD
Updated
Vaadin Charts renders charts with the Highcharts library and pins an exact version of it, 9.2.2 in Vaadin 22 to 24 and 12.2.0 in Vaadin 25, so an application cannot remove these vulnerabilities by upgrading Highcharts on its own. Highsoft disclosed several vulnerabilities in that library that are reachable through the chart configuration: writes to Object.prototype through dotted series.keys paths
Sources
- CVE.orgVulnerability recordCVE-2026-107588
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-107588
30-day exploitation probability 0.52%
first.org - NIST NVDVulnerability recordCVE-2026-107588
Vaadin Charts renders charts with the Highcharts library and pins an exact version of it, 9.2.2 in Vaadin 22 to 24 and 12.2.0 in Vaadin 25, so an application cannot remove these vulnerabilities by upgrading Highcharts on its own. Highsoft disclosed several vulnerabilities in that
nvd.nist.gov - Snyk Vulnerability DatabasePackage advisorySNYK-JAVA-COMVAADIN-21691577
Cross-site Scripting (XSS)
security.snyk.io - Snyk Vulnerability DatabasePackage advisorySNYK-JAVA-COMVAADIN-21691578
Cross-site Scripting (XSS)
security.snyk.io - Snyk Vulnerability DatabasePackage advisorySNYK-JAVA-COMVAADIN-21691579
Cross-site Scripting (XSS)
security.snyk.io - Snyk Vulnerability DatabasePackage advisorySNYK-JS-VAADINCHARTS-21691580
Cross-site Scripting (XSS)
security.snyk.io
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseOct 26, 2026
- Snyk Vulnerability DatabaseOct 26, 2026
- Snyk Vulnerability DatabaseOct 26, 2026
- Snyk Vulnerability DatabaseOct 26, 2026
- FIRST EPSSOct 23, 2026
- NIST NVDOct 22, 2026
- CVE.orgOct 22, 2026