Vulnerability · CVE-2026-109090
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
Published Oct 27, 2026 · catalog updated Oct 28, 2026 · OpenBSD OpenBSD
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-109090. EPSS is 0.26%. Act only if a listed version of OpenBSD OpenBSD is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-109089 · High
- CVE-2026-109088 · Medium
- CVE-2026-93536 · Medium
- CVE-2026-93524 · Medium
- CVE-2026-93523 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.26%
- Remediation
- Advisory link
- Affected products
- Alpine:v3.24 libxi
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Alpine:v3.24 libxi0 → 1.8.4-r0
How to fix CVE-2026-109090
Upgrade
CVE-2026-109090 lists a fix boundary at 1.8.4-r0. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1.8.4-r0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-109090. EPSS is 0.26%. Act only if a listed version of OpenBSD OpenBSD is installed.
Which versions are affected?
Compare what you have installed with 0 → 1.8.4-r0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.26%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · Trivy Vulnerability DB
Detected
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
Oct 28, 2026 · Trivy Vulnerability DB
Fix available
libxi fixed in 1.8.4-r0
Oct 28, 2026 · Trivy Vulnerability DB
Fix available
libxi fixed in 1.8.4-r0
Oct 28, 2026 · Trivy Vulnerability DB
Updated
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
Sources
- CVE.orgVulnerability recordCVE-2026-109090
Official CVE identifier
cve.org - OpenBSD ErrataVendor advisoryCVE-2026-109090
CVE-2026-109090 is named on the public OpenBSD Errata page.
openbsd.org - OpenSSF OSV / OSV ScannerPackage advisoryALPINE-CVE-2026-109090osv.dev
- Trivy Vulnerability DBPackage advisoryALPINE-CVE-2026-109090
A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when processed by libXi before 1.8.4.
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- OpenBSD ErrataNov 5, 2026
- Trivy Vulnerability DBOct 31, 2026
- OpenSSF OSV / OSV ScannerOct 30, 2026
- CVE.orgOct 28, 2026